.

リンネ

.

投稿記事by リンネ » 2019年2月06日(水) 14:21

.
最後に編集したユーザー リンネ on 2019年4月07日(日) 00:46 [ 編集 5 回目 ]

アバター
虚構の城跡
記事: 437
登録日時: 2016年9月23日(金) 16:58

Re: 特定の装備品を装備している間能力値の上限が変化する

投稿記事by 虚構の城跡 » 2019年2月06日(水) 15:34

まずは元々、パラメータが上限突破できるプラグインと加えて、装備品に何らかの装備条件(そのパラメータが一定以上とかレベル◯以上の時にしか装備できない等)を付け加えてみてはどうでしょうか?
YEP系なら一通り揃っています。
リンネ

.

投稿記事by リンネ » 2019年2月06日(水) 22:54

.
最後に編集したユーザー リンネ on 2019年4月07日(日) 17:01 [ 編集 1 回目 ]
アバター
虚構の城跡
記事: 437
登録日時: 2016年9月23日(金) 16:58

Re: 特定の装備品を装備している間能力値の上限が変化する

投稿記事by 虚構の城跡 » 2019年2月07日(木) 01:53

そうですか、YEP系を使わない方針ですか・・・。

自分が提案するプラグインは、おっしゃる通りYEP_Core engineとやな様の条件つきシリーズ、又はYEP_X_Equip Requirementsで規定以上のパラメータになった時に装備できる条件を利用し、上限突破している様に見せかけるという方法です。
もしくは
http://tm.lucky-duet.com/viewtopic.php?f=49&t=2665
こちらのプラグインで戦闘開始時に特定の装備をしている時にステートで能力値を底上げして、普段は上限突破はしないが、戦闘中だけ突破する様に調整。

まぁいずれにしろ代案ですので、装備時のみ限定的な上限突破するプラグインをどなたかに作ってもらうのが堅実かもしれませんね。

“MV:プラグイン素材のリクエスト” へ戻る