【解決済み】live2d cubism3.0をツクールmvエディタで動かせない

アバター
Slip
記事: 38
登録日時: 2016年7月06日(水) 22:05
連絡を取る:

【解決済み】live2d cubism3.0をツクールmvエディタで動かせない

投稿記事by Slip » 2018年6月11日(月) 22:19

こんにちは。slipと申します。
ツクールmv 上でlive2d cubism3.0のモデルを動かすプラグインを作成中です。
ブラウザ(chrome)では動作することが出来たのですが、ローカル環境(エディタ上)ではエラーが発生します。
スクリーンショット 2018-06-12 21.12.30.png

スクリーンショット 2018-06-12 21.12.36.png


このエラーを解決すればプラグインの実現にある程度目処がつきます。
ご助言等々よろしくお願いします。

https://twitter.com/kjmch2s/status/1006 ... 79745?s=21
最後に編集したユーザー Slip on 2018年6月13日(水) 21:40 [ 編集 1 回目 ]

アバター
トリアコンタン
記事: 1352
登録日時: 2015年11月10日(火) 21:13
お住まい: きのこ王国
連絡を取る:

Re: live2d cubism3.0をツクールmvエディタで動かせない

投稿記事by トリアコンタン » 2018年6月13日(水) 02:18

こんばんは!
プラグインに関する直接的な助言ではなくて恐縮ですが、
Chromeで動作するのであれば、NW.jsのバージョンアップによって問題が解決するかもしれません。
(すでに試されていたらすみません)

NW.jsのバージョンアップはツクールMV1.6.1を使用するか(Steamの場合以外は戻せないのでオススメしません)、以下の本家サイトからSDK版をダウンロードしてNW.exe(Windowsの場合)経由で起動します。

https://nwjs.io/
プラグイン関連のトラブルが発生した際の切り分けと報告の方法です。
http://qiita.com/triacontane/items/2e227e5b5ce9503a2c30

[Blog] : http://triacontane.blogspot.jp/
[Twitter]: https://twitter.com/triacontane/
[GitHub] : https://github.com/triacontane/
奏ねこま
記事: 425
登録日時: 2016年1月20日(水) 20:04

Re: live2d cubism3.0をツクールmvエディタで動かせない

投稿記事by 奏ねこま » 2018年6月13日(水) 10:23

エラー内容を見るに、そもそもlive2dcubismcore.min.jsをロードできていないようですが、
script要素の指定が間違っていたりしないでしょうか?
1.5.2にてこちらで確認した限りでは、当該jsファイルのロード自体に問題はありませんでした。

ただ、Cubism3ではECMAScript6で新たに追加された関数やメソッドを使用しているので、
どちらにしてもNW.jsの差し替えか、1.6.1へのバージョンアップは必要となります。
※該当関数やメソッドが特定できれば、1.5.2へ自前で追加するという手もあります。
※わかっている範囲だと、TypeArrayのforEachとslice、Arrayのfillなと。

ちなみに私も調査中の段階で、MVでLive2DCubism3を表示できたわけではありませんので、あしからず…
アバター
Slip
記事: 38
登録日時: 2016年7月06日(水) 22:05
連絡を取る:

Re: live2d cubism3.0をツクールmvエディタで動かせない

投稿記事by Slip » 2018年6月13日(水) 21:01

トリアコンタンさん
奏ねこまさん

早速の回答ありがとうございます。
画像のエラー原因はねこまさんの言う通り、パスが不正だったためでした。
別なエラーが発生しましたが、一旦、自分の方で解析進めます!

補足として、Chrome環境では動作するのですが、
LiveServerを起動した状態じゃないと起動しませんでした。
https://qiita.com/MasahiroHarada/items/ ... 272ea7e1e2

ありがとうございました!

“MV:質問” へ戻る