必要武器を2つ要求するスキル【解決済】

sato
記事: 4
登録日時: 2016年2月23日(火) 13:25

必要武器を2つ要求するスキル【解決済】

投稿記事by sato » 2016年11月18日(金) 21:33

こんにちは、お世話になってます。
今回はスキル関連でご指南頂きたく投稿しました。

タイトルの通り、必要武器を2つ要求するスキルを実装するためのプラグインをお願いしたいです。
ツクールのデフォルトでは「必要武器1」と「必要武器2」を設定できますが、どちらか一方を装備していればスキルが使えますよね。
これを、「必要武器1」「必要武器2」両方を装備していないとスキルが使えない、といったスキルを作りたいんです。
例えば二刀流のキャラで、片方に剣、片方に銃を装備していないと使えないスキル、といった感じです(両方剣や両方銃を装備していた場合は使用不可)

宜しくお願いいたします…!
また、既存のプラグインで似たようなものが既にありましたらお手数ですが教えていただけると幸いです。
最後に編集したユーザー sato on 2016年11月19日(土) 14:31 [ 編集 1 回目 ]

アバター
まっつUP
記事: 583
登録日時: 2016年8月11日(木) 15:38
お住まい: タケノコ王国

Re: 必要武器を2つ要求するスキル

投稿記事by まっつUP » 2016年11月18日(金) 23:01

sato様
お世話になります。
プラグインを作りました。

このプラグインを利用する場合は
readmeなどに「まっつUP」の名を入れてください。
また、素材のみの販売はダメです。
上記以外の規約等はございません。
もちろんツクールMVで使用する前提です。
何か不具合ありましたら気軽にどうぞ。
添付ファイル
WtypeStrict.js
(1.45 KiB) ダウンロード数: 18 回
RPGで笑顔を・・・

拙作「Dragon Claw」
http://www.freem.ne.jp/win/game/12816

断固タケノコ派の男のツイッター
https://twitter.com/mattuup
sato
記事: 4
登録日時: 2016年2月23日(火) 13:25

Re: 必要武器を2つ要求するスキル

投稿記事by sato » 2016年11月19日(土) 14:30

まっつUP 様

早速作っていただきありがとうございました!
早速確認してみましたが、思っていた通りのスキルが作ることができました!
本当にありがとうございましたm(_ _)m

“MV:プラグイン素材のリクエスト” へ戻る